Page 1 of 2

Can't connect with OPC-UA Servers

PostPosted: Fri Oct 21, 2016 1:27 pm
by vitor_pinheiro/sicpa_com
Hello guys,

I'm receiving the following errors when trying to connect with PLC's OPC-UA servers:

"Error reading devices asset"
"Error reading assets"

I've read all the available docs and tested the software in two different machines with different operational systems (windows 7 and linux mint 17) and I keep having the same errors..

Any idea in what is wrong?

Please see the screenshots attached.

Thanks,
Vitor


The attachment Aggregate_error_MsgBox.jpg[/attachment

[attachment=0]Aggregate_OPCUA_properties.jpg
is no longer available

Re: Can't connect with OPC-UA Servers

PostPosted: Fri Oct 21, 2016 1:33 pm
by vitor_pinheiro/sicpa_com
Including some screen shots

Re: Can't connect with OPC-UA Servers

PostPosted: Fri Oct 21, 2016 1:36 pm
by vitor_pinheiro/sicpa_com
Including some screen shots

Re: Can't connect with OPC-UA Servers

PostPosted: Mon Oct 24, 2016 11:29 am
by anton_logoyskiy/tibbo_com
Hi Vitor

Please check your Address Space Source Paths settings and credentials.
What is the name of you OPC UA server?

Best Regard,
Anton Logoyskiy

Re: Can't connect with OPC-UA Servers

PostPosted: Mon Oct 24, 2016 12:48 pm
by vitor_pinheiro/sicpa_com
Hi Anton,

Thanks for reply.

What exactly I have to check in Address Space Source Paths settings? I connected to the server with a third part OPC-UA client application and got three directories on first level (Objects, Views and Types). I've already added the other two directories on "Address Space Source Paths settings" and got the same error.

About the credentials, I'm not using any authentication on the server, so I think there is nothing to set on those fields, right?

Best regards,
Vitor

Re: Can't connect with OPC-UA Servers

PostPosted: Wed Oct 26, 2016 11:02 am
by vitor_pinheiro/sicpa_com
up

Re: Can't connect with OPC-UA Servers

PostPosted: Mon Oct 31, 2016 8:18 am
by anton_logoyskiy/tibbo_com
Hi Vitor,

It looks like you have configured Address Space Source Paths correctly.
But you haven't mentioned what is the full name of your OPC UA server?

Best Regards,
Anton Logoyskiy

Re: Can't connect with OPC-UA Servers

PostPosted: Mon Oct 31, 2016 6:28 pm
by vitor_pinheiro/sicpa_com
Hi Anton,

What do you mean about OPC UA server's full name? Is it the name of the PLC where the server is running?

I put the name of the PLC (as it appears on Windows CE) in the field "name" of the device configuration, which is: PLCPCS, as you can see on the screenshot in the first post of this topic.

Just an update: I have tested the communication with a Modbus TCP server running in the same PLC and had the same error.

After created, both devices are showed with status online and not synchronized. It is probably a problem with synchronization in general, not only with OPC-UA servers.

Is there any configuration that I have to do before the creation of devices and which can produces this kind of error?

Thanks,
Vitor

Re: Can't connect with OPC-UA Servers

PostPosted: Wed Nov 02, 2016 5:56 am
by anton_logoyskiy/tibbo_com
Hi Vitor,

I request the brand name of your OPC-UA server, or the name of company which developed it.
Basically you should add Modbus registers manually:

http://aggregate.tibbo.com/docs/en/index.htm?ls_drivers_modbus.htm

I think it helps you to get data through Modbus.

BR/Anton

Re: Can't connect with OPC-UA Servers

PostPosted: Thu Nov 03, 2016 1:33 pm
by vitor_pinheiro/sicpa_com
Anton,

I am using the Beckhoff's TwinCAT OPC-UA Server CE (TS6100-0030) running in a Beckhoff CX5020 WinCE PLC.

Regards.

Vitor