Internet of Things Integration Platform
Remote Monitoring, M2M and Device Management Software Platform

Problem with Aggregate Agent

Questions related to usage of AggreGate SDK, Driver Development Kit, Plugin SDK, Agent SDK and APIs for Java, .NET, C/C++, Android, Tibbo BASIC etc.

Problem with Aggregate Agent

Postby ivan_karadenizov/frodexim_com » Fri Jan 27, 2017 9:25 am

Hi all,

There is a problem with communication between Aggregate Server and Agent devices.

During server operation, ID of communication request/respond is increasing. In Aggregate Library (aggregate.tbs line 74) the id have size 8. When id reach 99999999, it does not roll over to 0, but increase to 100000000, the server "hangs" and all devices become offline, because controllers can't process the request. And then the server must be restarted.

I rebuilded the project with bigger string (10) and it is working fine for now. But the problem is there, just will take more time to occur.
ivan_karadenizov/frodexim_com
 
Posts: 2
Joined: Wed Sep 07, 2016 2:16 pm

Re: Problem with Aggregate Agent

Postby anton_logoyskiy/tibbo_com » Wed Feb 08, 2017 5:44 am

Hi Ivan,

Please tell what Tibbo devices are you using?
What version of firmware you used with them?
Also please provide version of AggreGate server and AggreGate API?

BR/Anton
anton_logoyskiy/tibbo_com
 
Posts: 94
Joined: Wed Jul 22, 2015 10:05 am


Return to Development and Integration

Who is online

Users browsing this forum: No registered users and 0 guests